You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/bloomfilter/bloomfilter-2.0.1.0-r1.ebuild

40 lines
844 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.8.1.0.9999
CABAL_HACKAGE_REVISION=2
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Pure and impure Bloom Filter implementations"
HOMEPAGE="https://github.com/bos/bloomfilter"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux"
PATCHES=(
"${FILESDIR}/${PN}-2.0.1.0-ghc-9_2-fix.patch"
)
CABAL_CHDEPS=(
'base >= 4.4 && < 4.16' 'base >= 4.4'
'base >= 4.4 && < 4.16' 'base >= 4.4'
)
RDEPEND=">=dev-lang/ghc-8.8.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-3.0.0.0
test? (
>=dev-haskell/quickcheck-2.5
dev-haskell/random
dev-haskell/test-framework
dev-haskell/test-framework-quickcheck2
)
"