You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/doctest/doctest-0.22.0.ebuild

36 lines
962 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.8.4.0.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Test interactive Haskell examples"
HOMEPAGE="https://github.com/sol/doctest#readme"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
RDEPEND=">=dev-haskell/base-compat-0.7.0:=[profile?]
>=dev-haskell/code-page-0.1:=[profile?]
>=dev-haskell/ghc-paths-0.1.0.9:=[profile?]
>=dev-haskell/syb-0.3:=[profile?]
>=dev-lang/ghc-8.0:=[profile?] <dev-lang/ghc-9.7:=[profile?]
>=dev-lang/ghc-8.10.6:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-3.2.1.0
test? ( >=dev-haskell/hspec-2.3.0
>=dev-haskell/hspec-core-2.3.0
dev-haskell/hunit
dev-haskell/mockery
>=dev-haskell/quickcheck-2.13.1
dev-haskell/setenv
>=dev-haskell/silently-1.2.4
>=dev-haskell/stringbuilder-0.4 )
"