You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/ed25519/ed25519-0.0.5.0-r1.ebuild

40 lines
919 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.8.4.0.9999
#hackport: flags: +no-donna,+test-doctests,+test-properties,-test-hlint
CABAL_HACKAGE_REVISION=7
CABAL_FEATURES="lib profile haddock hoogle hscolour" # test-suite"
inherit haskell-cabal
DESCRIPTION="Ed25519 cryptographic signatures"
HOMEPAGE="https://thoughtpolice.github.com/hs-ed25519"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
RESTRICT=test # bitrotten test suite
RDEPEND=">=dev-lang/ghc-8.8.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-3.0.0.0
"
# test? (
# >=dev-haskell/doctest-0.10 <dev-haskell/doctest-0.12
# >=dev-haskell/quickcheck-2.4 <dev-haskell/quickcheck-2.9
# )
src_configure() {
haskell-cabal_src_configure \
--flag=no-donna \
--flag=test-doctests \
--flag=-test-hlint \
--flag=test-properties
}