You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/lpeg/lpeg-1.0.4.ebuild

32 lines
788 B

This file contains ambiguous Unicode characters!

This file contains ambiguous Unicode characters that may be confused with others in your current locale. If your use case is intentional and legitimate, you can safely ignore this warning. Use the Escape button to highlight these characters.

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.8.2.0.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="LPeg Parsing Expression Grammars For Lua"
HOMEPAGE="https://hslua.org/"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE="rely-on-shared-lpeg-library"
RDEPEND=">=dev-haskell/lua-2.1:=[profile?] <dev-haskell/lua-2.4:=[profile?]
>=dev-lang/ghc-8.8.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-3.0.0.0
test? ( >=dev-haskell/tasty-0.11
>=dev-haskell/tasty-hunit-0.9 )
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag rely-on-shared-lpeg-library rely-on-shared-lpeg-library)
}