You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/parsers/parsers-0.12.10-r1.ebuild

58 lines
1.8 KiB

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.7.1.1.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
CABAL_HACKAGE_REVISION="2"
inherit haskell-cabal
CABAL_FILE="${S}/${PN}.cabal"
CABAL_DISTFILE="${P}-rev${CABAL_HACKAGE_REVISION}.cabal"
DESCRIPTION="Parsing combinators"
HOMEPAGE="https://github.com/ekmett/parsers/"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz
https://hackage.haskell.org/package/${P}/revision/${CABAL_HACKAGE_REVISION}.cabal
-> ${CABAL_DISTFILE}"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE="+attoparsec +binary +parsec"
RDEPEND=">=dev-haskell/base-orphans-0.3:=[profile?] <dev-haskell/base-orphans-1:=[profile?]
>=dev-haskell/charset-0.3:=[profile?] <dev-haskell/charset-1:=[profile?]
>=dev-haskell/scientific-0.3:=[profile?] <dev-haskell/scientific-0.4:=[profile?]
>=dev-haskell/semigroups-0.12:=[profile?] <dev-haskell/semigroups-1:=[profile?]
>=dev-haskell/unordered-containers-0.2:=[profile?] <dev-haskell/unordered-containers-0.3:=[profile?]
>=dev-lang/ghc-8.4.3:=
attoparsec? ( >=dev-haskell/attoparsec-0.12.1.4:=[profile?] <dev-haskell/attoparsec-0.15:=[profile?] )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.2.0.1
test? ( dev-haskell/quickcheck
dev-haskell/quickcheck-instances )
"
BDEPEND="app-text/dos2unix"
src_prepare() {
# pull revised cabal from upstream
cp "${DISTDIR}/${CABAL_DISTFILE}" "${CABAL_FILE}" || die
# Convert to unix line endings
dos2unix "${CABAL_FILE}" || die
# Apply patches *after* pulling the revised cabal
default
}
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag attoparsec attoparsec) \
$(cabal_flag binary binary) \
$(cabal_flag parsec parsec)
}