You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/prettyprinter-ansi-terminal/prettyprinter-ansi-terminal...

34 lines
944 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.7.3.0
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="ANSI terminal backend for the »prettyprinter« package"
HOMEPAGE="https://github.com/quchen/prettyprinter"
LICENSE="BSD-2"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
RDEPEND=">=dev-haskell/ansi-terminal-0.4.0:=[profile?]
>=dev-haskell/prettyprinter-1.7.0:=[profile?]
>=dev-lang/ghc-8.4.3:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.2.0.1
test? ( >=dev-haskell/doctest-0.9 )
"
pkg_pretend() {
if use test; then
ewarn "The \"test\" USE flag for this package creates cycles within the"
ewarn "dependency graph. This may give you problems during 'haskell-updater' runs."
ewarn "It is recommended to leave it disabled unless explicitly testing the package."
fi
}