You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/random-bytestring/random-bytestring-0.1.4.ebuild

32 lines
758 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.7.9999
CABAL_FEATURES="lib profile haddock hoogle hscolour"
inherit haskell-cabal
DESCRIPTION="Efficient generation of random bytestrings"
HOMEPAGE="https://www.github.com/larskuhtz/random-bytestring"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="MIT"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE="+pcg"
RDEPEND=">=dev-haskell/mwc-random-0.13:=[profile?]
>=dev-lang/ghc-8.4.3:=
pcg? ( >=dev-haskell/pcg-random-0.1:=[profile?] )
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-2.2.0.1
"
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag pcg with-pcg)
}