You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-haskell/simple-sendfile/simple-sendfile-0.2.30-r1.e...

40 lines
917 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# ebuild generated by hackport 0.6.3
CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
inherit haskell-cabal
DESCRIPTION="Cross platform library for the sendfile system call"
HOMEPAGE="https://hackage.haskell.org/package/simple-sendfile"
SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
IUSE="+allow-bsd"
RDEPEND="dev-haskell/network:=[profile?]
>=dev-lang/ghc-7.10.1:=
"
DEPEND="${RDEPEND}
>=dev-haskell/cabal-1.22.2.0
test? ( dev-haskell/conduit
dev-haskell/conduit-extra
>=dev-haskell/hspec-1.3
dev-haskell/hunit
dev-haskell/resourcet )
"
PATCHES=(
"${FILESDIR}/${PN}-0.2.30-musl-1.2.4.patch"
)
src_configure() {
haskell-cabal_src_configure \
$(cabal_flag allow-bsd allow-bsd)
}