You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/denonavr/denonavr-0.11.4.ebuild

41 lines
958 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="xml(+)"
inherit distutils-r1 pypi
DESCRIPTION="Automation Library for Denon AVR receivers"
HOMEPAGE="
https://github.com/ol-iver/denonavr/
https://pypi.org/project/denonavr/
"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
>=dev-python/asyncstdlib-3.10.2[${PYTHON_USEDEP}]
>=dev-python/attrs-21.2.0[${PYTHON_USEDEP}]
>=dev-python/defusedxml-0.7.1[${PYTHON_USEDEP}]
>=dev-python/httpx-0.23.1[${PYTHON_USEDEP}]
>=dev-python/netifaces-0.11.0[${PYTHON_USEDEP}]
$(python_gen_cond_dep '
>=dev-python/async-timeout-4.0.2[${PYTHON_USEDEP}]
' 3.{8..10})
"
BDEPEND="
test? (
dev-python/pytest-asyncio[${PYTHON_USEDEP}]
dev-python/pytest-httpx[${PYTHON_USEDEP}]
dev-python/pytest-timeout[${PYTHON_USEDEP}]
)
"
distutils_enable_tests pytest