You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/jsonext/jsonext-0.4.2-r1.ebuild

31 lines
602 B

# Copyright 2019-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
DESCRIPTION="Well-structured helpers for serializing commonly encountered structures to JSON"
HOMEPAGE="
https://github.com/mbr/jsonext/
https://pypi.org/project/jsonext/
"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm64 x86"
RDEPEND="
dev-python/arrow[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
distutils_enable_tests pytest
python_test() {
epytest --doctest-modules jsonext
}