You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/pygal/pygal-3.0.4-r1.ebuild

55 lines
1.2 KiB

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
PYTHON_REQ_USE="xml(+)"
inherit distutils-r1 optfeature
DESCRIPTION="A python SVG charts generator"
HOMEPAGE="
https://github.com/Kozea/pygal/
https://pypi.org/project/pygal/
"
SRC_URI="
https://github.com/Kozea/pygal/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz
"
LICENSE="LGPL-3+"
SLOT="0"
KEYWORDS="amd64 arm64 ~riscv x86"
RDEPEND="
dev-python/importlib-metadata[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/lxml[${PYTHON_USEDEP}]
dev-python/pyquery[${PYTHON_USEDEP}]
media-gfx/cairosvg[${PYTHON_USEDEP}]
)
"
# CHANGELOG is a symlink to docs/changelog.rst
DOCS=( docs/changelog.rst README.md )
distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
EPYTEST_XDIST=1
distutils_enable_tests pytest
python_prepare_all() {
# Not actually required unless we want to do setup.py test
# https://github.com/Kozea/pygal/issues/430
sed -i -e "/setup_requires/d" setup.py || die
distutils-r1_python_prepare_all
}
pkg_postinst() {
optfeature "improving rendering speed" "dev-python/lxml"
optfeature "png rendering" "dev-python/cairosvg"
}