You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/testresources/testresources-2.0.1-r3.ebuild

38 lines
848 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} pypy3 )
inherit distutils-r1 pypi
DESCRIPTION="A pyunit extension for managing expensive test resources"
HOMEPAGE="
https://launchpad.net/testresources/
https://github.com/testing-cabal/testresources/
https://pypi.org/project/testresources/
"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux"
RDEPEND="
dev-python/pbr[${PYTHON_USEDEP}]
"
BDEPEND="
dev-python/pbr[${PYTHON_USEDEP}]
test? (
dev-python/testtools[${PYTHON_USEDEP}]
dev-python/fixtures[${PYTHON_USEDEP}]
)
"
PATCHES=(
"${FILESDIR}/${P}-py312-tests.patch"
)
distutils_enable_tests unittest