You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/x-wr-timezone/x-wr-timezone-0.0.6.ebuild

35 lines
699 B

# Copyright 2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="Convert calendars using X-WR-TIMEZONE to standard ones"
HOMEPAGE="
https://github.com/niccokunzmann/x-wr-timezone/
https://pypi.org/project/x-wr-timezone/
"
SRC_URI="
https://github.com/niccokunzmann/x-wr-timezone/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
"
LICENSE="LGPL-3+"
SLOT="0"
KEYWORDS="~amd64 ~arm64 ~x86"
RDEPEND="
>=dev-python/icalendar-5.0.11[${PYTHON_USEDEP}]
dev-python/pytz[${PYTHON_USEDEP}]
"
distutils_enable_tests pytest
EPYTEST_IGNORE=(
test/test_readme.py
)