22 lines
616 B
Bash
22 lines
616 B
Bash
# Copyright 1999-2024 Gentoo Authors
|
|
# Distributed under the terms of the GNU General Public License v2
|
|
|
|
EAPI=8
|
|
|
|
DISTUTILS_USE_PEP517=setuptools
|
|
PYPI_NO_NORMALIZE=1
|
|
PYTHON_REQ_USE="sqlite"
|
|
PYTHON_COMPAT=( python3_{10..12} )
|
|
inherit distutils-r1 pypi
|
|
|
|
DESCRIPTION="BuildBot base web interface, use with buildbot-{console-view,waterfall-view}..."
|
|
HOMEPAGE="https://buildbot.net/
|
|
https://github.com/buildbot/buildbot
|
|
https://pypi.org/project/buildbot-www/"
|
|
|
|
LICENSE="GPL-2"
|
|
SLOT="0"
|
|
KEYWORDS="amd64 ~arm64 ~riscv ~amd64-linux ~x86-linux"
|
|
|
|
RDEPEND="~dev-util/buildbot-pkg-${PV}[${PYTHON_USEDEP}]"
|
|
BDEPEND="${RDEPEND}"
|