You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-apps/kdenetwork-filesharing/kdenetwork-filesharing-24.0...

40 lines
828 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
KFMIN=6.0.0
QTMIN=6.6.2
inherit ecm gear.kde.org
DESCRIPTION="Samba filesharing plugin for file properties"
HOMEPAGE="https://apps.kde.org/kdenetwork_filesharing/"
LICENSE="GPL-2" # TODO: CHECK
SLOT="6"
KEYWORDS="~amd64"
IUSE=""
DEPEND="
dev-libs/qcoro
>=dev-qt/qtbase-${QTMIN}:6[gui,widgets]
>=dev-qt/qtdeclarative-${QTMIN}:6
>=kde-frameworks/kcompletion-${KFMIN}:6
>=kde-frameworks/kcoreaddons-${KFMIN}:6
>=kde-frameworks/ki18n-${KFMIN}:6
>=kde-frameworks/kio-${KFMIN}:6
>=kde-frameworks/kwidgetsaddons-${KFMIN}:6
"
RDEPEND="${DEPEND}
>=kde-frameworks/kirigami-${KFMIN}:6
net-fs/samba
"
src_configure() {
local mycmakeargs=(
-DCMAKE_DISABLE_FIND_PACKAGE_PackageKitQt6=ON
)
ecm_src_configure
}