You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-apps/kdepim-runtime/kdepim-runtime-24.02.2.ebuild

83 lines
2.3 KiB

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
ECM_TEST="forceoptional"
PVCUT=$(ver_cut 1-3)
KFMIN=6.0.0
QTMIN=6.6.2
inherit ecm gear.kde.org
DESCRIPTION="Runtime plugin collection to extend the functionality of KDE PIM"
HOMEPAGE="https://apps.kde.org/kontact/"
LICENSE="GPL-2+ LGPL-2.1+"
SLOT="6"
KEYWORDS="~amd64"
IUSE="speech"
RESTRICT="test"
# TODO etebase, kolab
RDEPEND="
>=app-crypt/qca-2.3.7:2[qt6]
dev-libs/cyrus-sasl:2
>=dev-libs/qtkeychain-0.14.1-r1:=[qt6]
>=dev-libs/ktextaddons-1.5.3:6
>=dev-qt/qtbase-${QTMIN}:6[concurrent,dbus,gui,network,widgets,xml]
>=dev-qt/qtnetworkauth-${QTMIN}:6
>=dev-qt/qtwebengine-${QTMIN}:6[widgets]
>=kde-apps/akonadi-${PVCUT}:6
>=kde-apps/akonadi-calendar-${PVCUT}:6
>=kde-apps/akonadi-contacts-${PVCUT}:6
>=kde-apps/akonadi-mime-${PVCUT}:6
>=kde-apps/akonadi-notes-${PVCUT}:6
>=kde-apps/kcalutils-${PVCUT}:6
>=kde-apps/kidentitymanagement-${PVCUT}:6
>=kde-apps/kimap-${PVCUT}:6
>=kde-apps/kldap-${PVCUT}:6
>=kde-apps/kmailtransport-${PVCUT}:6
>=kde-apps/kmbox-${PVCUT}:6
>=kde-apps/kmime-${PVCUT}:6
>=kde-apps/libkgapi-${PVCUT}:6
>=kde-frameworks/kcalendarcore-${KFMIN}:6
>=kde-frameworks/kcmutils-${KFMIN}:6
>=kde-frameworks/kcodecs-${KFMIN}:6
>=kde-frameworks/kcompletion-${KFMIN}:6
>=kde-frameworks/kconfig-${KFMIN}:6
>=kde-frameworks/kconfigwidgets-${KFMIN}:6
>=kde-frameworks/kcontacts-${KFMIN}:6
>=kde-frameworks/kcoreaddons-${KFMIN}:6
>=kde-frameworks/kdav-${KFMIN}:6
>=kde-frameworks/ki18n-${KFMIN}:6
>=kde-frameworks/kio-${KFMIN}:6
>=kde-frameworks/kitemmodels-${KFMIN}:6
>=kde-frameworks/kjobwidgets-${KFMIN}:6
>=kde-frameworks/knotifications-${KFMIN}:6
>=kde-frameworks/knotifyconfig-${KFMIN}:6
>=kde-frameworks/kservice-${KFMIN}:6
>=kde-frameworks/ktextwidgets-${KFMIN}:6
>=kde-frameworks/kwallet-${KFMIN}:6
>=kde-frameworks/kwidgetsaddons-${KFMIN}:6
>=kde-frameworks/kwindowsystem-${KFMIN}:6
>=kde-frameworks/kxmlgui-${KFMIN}:6
speech? ( >=dev-qt/qtspeech-${QTMIN}:6 )
"
DEPEND="${RDEPEND}
test? (
>=kde-apps/akonadi-${PVCUT}:6[tools]
>=kde-apps/kimap-${PVCUT}:6[test]
)
"
src_configure() {
local mycmakeargs=(
-DKDEPIM_RUN_AKONADI_TEST=$(usex test)
-DCMAKE_DISABLE_FIND_PACKAGE_Etebase=ON
-DCMAKE_DISABLE_FIND_PACKAGE_Libkolabxml=ON
$(cmake_use_find_package speech Qt6TextToSpeech)
)
ecm_src_configure
}