You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-apps/kmag/kmag-24.02.2.ebuild

39 lines
879 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
ECM_HANDBOOK="forceoptional"
KFMIN=6.0.0
QTMIN=6.6.2
inherit ecm gear.kde.org
DESCRIPTION="KDE screen magnifier"
HOMEPAGE="https://apps.kde.org/kmag/"
LICENSE="GPL-2" # TODO: CHECK
SLOT="6"
KEYWORDS="~amd64"
IUSE="keyboardfocus"
DEPEND="
>=dev-qt/qtbase-${QTMIN}:6[gui,widgets]
>=kde-frameworks/kconfig-${KFMIN}:6
>=kde-frameworks/kconfigwidgets-${KFMIN}:6
>=kde-frameworks/kcoreaddons-${KFMIN}:6
>=kde-frameworks/ki18n-${KFMIN}:6
>=kde-frameworks/kio-${KFMIN}:6
>=kde-frameworks/kwidgetsaddons-${KFMIN}:6
>=kde-frameworks/kxmlgui-${KFMIN}:6
keyboardfocus? ( >=media-libs/libqaccessibilityclient-0.6:6 )
"
RDEPEND="${DEPEND}"
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package keyboardfocus QAccessibilityClient)
)
ecm_src_configure
}