You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/kde-apps/korganizer/korganizer-24.02.2.ebuild

79 lines
2.3 KiB

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
ECM_HANDBOOK="optional"
ECM_TEST="forceoptional"
PVCUT=$(ver_cut 1-3)
KFMIN=6.0.0
QTMIN=6.6.2
inherit ecm gear.kde.org
DESCRIPTION="Organizational assistant, providing calendars and other similar functionality"
HOMEPAGE="https://apps.kde.org/korganizer/"
LICENSE="GPL-2+ handbook? ( FDL-1.2+ )"
SLOT="6"
KEYWORDS="~amd64"
IUSE="telemetry"
# testkodaymatrix is broken, akonadi* tests need DBus, bug #665686
RESTRICT="test"
COMMON_DEPEND="
>=dev-qt/qtbase-${QTMIN}:6[dbus,gui,widgets]
>=dev-qt/qttools-${QTMIN}:6[widgets]
>=kde-apps/akonadi-${PVCUT}:6
>=kde-apps/akonadi-calendar-${PVCUT}:6
>=kde-apps/akonadi-contacts-${PVCUT}:6
>=kde-apps/akonadi-notes-${PVCUT}:6
>=kde-apps/calendarsupport-${PVCUT}:6
>=kde-apps/eventviews-${PVCUT}:6
>=kde-apps/incidenceeditor-${PVCUT}:6
>=kde-apps/kcalutils-${PVCUT}:6
>=kde-apps/kidentitymanagement-${PVCUT}:6
>=kde-apps/kmailtransport-${PVCUT}:6
>=kde-apps/kmime-${PVCUT}:6
>=kde-apps/kontactinterface-${PVCUT}:6
>=kde-apps/libkdepim-${PVCUT}:6
>=kde-apps/pimcommon-${PVCUT}:6
>=kde-frameworks/kcalendarcore-${KFMIN}:6
>=kde-frameworks/kcmutils-${KFMIN}:6
>=kde-frameworks/kconfig-${KFMIN}:6
>=kde-frameworks/kconfigwidgets-${KFMIN}:6
>=kde-frameworks/kcontacts-${KFMIN}:6
>=kde-frameworks/kcoreaddons-${KFMIN}:6
>=kde-frameworks/kcrash-${KFMIN}:6
>=kde-frameworks/kholidays-${KFMIN}:6
>=kde-frameworks/ki18n-${KFMIN}:6
>=kde-frameworks/kiconthemes-${KFMIN}:6
>=kde-frameworks/kio-${KFMIN}:6
>=kde-frameworks/kitemmodels-${KFMIN}:6
>=kde-frameworks/kitemviews-${KFMIN}:6
>=kde-frameworks/kjobwidgets-${KFMIN}:6
>=kde-frameworks/knewstuff-${KFMIN}:6
>=kde-frameworks/kparts-${KFMIN}:6
>=kde-frameworks/kwidgetsaddons-${KFMIN}:6
>=kde-frameworks/kwindowsystem-${KFMIN}:6
>=kde-frameworks/kxmlgui-${KFMIN}:6
x11-libs/libX11
telemetry? ( >=kde-frameworks/kuserfeedback-${KFMIN}:6 )
"
DEPEND="${COMMON_DEPEND}
>=kde-apps/kldap-${PVCUT}:6
test? ( >=kde-apps/akonadi-${PVCUT}:6[sqlite] )
"
RDEPEND="${COMMON_DEPEND}
>=kde-apps/kdepim-runtime-${PVCUT}:6
"
BDEPEND="test? ( >=kde-apps/akonadi-${PVCUT}:6[tools] )"
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package telemetry KF6UserFeedback)
)
ecm_src_configure
}