You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sci-libs/hipFFT/hipFFT-5.1.3-r1.ebuild

45 lines
1.0 KiB

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
ROCM_VERSION=${PV}
inherit cmake rocm
DESCRIPTION="CU / ROCM agnostic hip FFT implementation"
HOMEPAGE="https://github.com/ROCmSoftwarePlatform/hipFFT"
SRC_URI="https://github.com/ROCmSoftwarePlatform/hipFFT/archive/refs/tags/rocm-${PV}.tar.gz -> hipFFT-rocm-${PV}.tar.gz"
REQUIRED_USE="${ROCM_REQUIRED_USE}"
LICENSE="MIT"
KEYWORDS="~amd64"
SLOT="0/$(ver_cut 1-2)"
RESTRICT="test"
RDEPEND="dev-util/hip
sci-libs/rocFFT:${SLOT}[${ROCM_USEDEP}]"
DEPEND="${RDEPEND}"
BDEPEND=""
S="${WORKDIR}/hipFFT-rocm-${PV}"
PATCHES=(
"${FILESDIR}/${PN}-5.1.3_hip-config.patch"
"${FILESDIR}/${PN}-5.1.3-gentoo-install-locations.patch"
"${FILESDIR}/${PN}-5.0.2-remove-git-dependency.patch"
"${FILESDIR}/${PN}-4.3.0-add-complex-header.patch"
)
src_configure() {
local mycmakeargs=(
-DCMAKE_INSTALL_INCLUDEDIR="include/hipfft"
-DROCM_SYMLINK_LIBS=OFF
-DBUILD_CLIENTS_TESTS=OFF
-DBUILD_CLIENTS_RIDER=OFF
)
CXX=hipcc cmake_src_configure
}