You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sec-keys/openpgp-keys-llvm/openpgp-keys-llvm-16.0.4.eb...

25 lines
752 B

# Copyright 2022-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DESCRIPTION="OpenPGP keys used to sign LLVM releases"
HOMEPAGE="https://github.com/llvm/llvm-project/releases/tag/llvmorg-16.0.4/"
SRC_URI="
https://pgp.mit.edu/pks/lookup?op=get&search=0xA2C794A986419D8A
-> ${P}-tstellar.asc
https://keyserver.ubuntu.com/pks/lookup?op=get&search=0xd574bd5d1d0e98895e3bf90044f2485e45d59042
-> ${P}-tobiashieta.asc
"
S="${WORKDIR}"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
src_install() {
local files=( ${A} )
insinto /usr/share/openpgp-keys
newins - llvm.asc < <(cat "${files[@]/#/${DISTDIR}/}" || die)
}