You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sys-apps/cracklib-words/cracklib-words-2.9.11.ebuild

28 lines
728 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
# Note: ideally bump with sys-libs/cracklib
DESCRIPTION="Large set of crack/cracklib dictionaries"
HOMEPAGE="https://github.com/cracklib/cracklib/"
SRC_URI="https://github.com/cracklib/cracklib/releases/download/v${PV}/${P}.xz"
S="${WORKDIR}"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86"
src_install() {
insinto /usr/share/dict
newins ${P} ${PN}
}
pkg_postinst() {
if [[ -n ${ROOT} ]] && create-cracklib-dict -h >&/dev/null ; then
ebegin "Regenerating cracklib dictionary"
create-cracklib-dict /usr/share/dict/* >/dev/null
eend $?
fi
}