You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/fbdesk/fbdesk-1.4.1-r1.ebuild

41 lines
844 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit flag-o-matic
DESCRIPTION="fluxbox-util application that creates and manage icons on your Fluxbox desktop"
HOMEPAGE="http://fluxbox.sourceforge.net/fbdesk/"
SRC_URI="mirror://gentoo/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 ~ia64 ppc sparc x86"
IUSE="debug png"
RDEPEND="x11-libs/libX11
x11-libs/libXext
x11-libs/libXpm
x11-libs/libXrender
x11-libs/libXft
media-libs/imlib2[X]
png? ( media-libs/libpng:0= )"
DEPEND="${RDEPEND}
x11-base/xorg-proto"
PATCHES=(
"${FILESDIR}/${P}-gcc-4.3.patch"
"${FILESDIR}/${P}-libpng14.patch"
"${FILESDIR}/${P}-libpng15.patch"
"${FILESDIR}/${P}-fix-c++14.patch"
)
src_configure() {
append-cxxflags -std=c++14
econf \
$(use_enable debug) \
$(use_enable png)
}