You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/kaqaz/kaqaz-1.2.0-r4.ebuild

56 lines
1.0 KiB

# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit qmake-utils
DESCRIPTION="Modern note manager"
HOMEPAGE="https://github.com/sialan-labs/kaqaz/"
if [[ ${PV} = *9999* ]]; then
inherit git-r3
EGIT_REPO_URI="https://github.com/sialan-labs/kaqaz.git"
else
SRC_URI="https://github.com/sialan-labs/kaqaz/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="GPL-3+"
SLOT="0"
IUSE=""
RDEPEND="
dev-qt/qtcore:5
dev-qt/qtdeclarative:5
dev-qt/qtgraphicaleffects:5
dev-qt/qtgui:5
dev-qt/qtmultimedia:5[qml]
dev-qt/qtnetwork:5[ssl]
dev-qt/qtpositioning:5
dev-qt/qtsingleapplication[qt5(+),X]
dev-qt/qtsensors:5
dev-qt/qtsql:5[sqlite]
dev-qt/qtquickcontrols:5
dev-qt/qtwidgets:5
dev-qt/qtxml:5
"
DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}/${P}-qt55.patch"
"${FILESDIR}/${P}-unbundle-qtsingleapplication.patch"
)
src_prepare() {
default
rm -r sialantools/qtsingleapplication || die
}
src_configure() {
eqmake5
}
src_install() {
emake install INSTALL_ROOT="${D}"
}