You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/set_opacity/set_opacity-9999.ebuild

33 lines
600 B

# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit git-r3 toolchain-funcs
EGIT_REPO_URI="https://github.com/XVilka/set_opacity.git"
DESCRIPTION="Tool for set real compositing for windows through window's id, process' pid etc."
HOMEPAGE="https://github.com/XVilka/set_opacity"
SRC_URI=""
LICENSE="GPL-2"
SLOT="0"
IUSE=""
DEPEND="x11-libs/libXdamage
x11-libs/libXcomposite
x11-libs/libXfixes
x11-libs/libXrender"
RDEPEND=${DEPEND}
KEYWORDS=""
src_compile() {
emake CC="$(tc-getCC)"
}
src_install() {
dobin set_opacity
}