You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/spnavcfg/spnavcfg-1.0.ebuild

40 lines
857 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs qmake-utils
DESCRIPTION="GTK-based GUI to configure a space navigator device"
HOMEPAGE="http://spacenav.sourceforge.net/"
SRC_URI="https://downloads.sourceforge.net/project/spacenav/spacenavd%20config%20gui/${PN}%20${PV}/${P}.tar.gz"
LICENSE="GPL-3"
SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
COMMON_DEPEND=">=dev-libs/libspnav-1[X]
dev-qt/qtcore
dev-qt/qtgui
dev-qt/qtwidgets
x11-libs/libX11"
DEPEND="${COMMON_DEPEND}
virtual/pkgconfig"
RDEPEND="${COMMON_DEPEND}
>=app-misc/spacenavd-1[X]"
src_configure() {
econf --disable-debug --disable-opt
}
src_compile() {
local args=(
CC="$(tc-getCC)"
MOC="$(qt5_get_bindir)/moc"
RCC="$(qt5_get_bindir)/rcc"
UIC="$(qt5_get_bindir)/uic"
)
emake "${args[@]}"
}