You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/x11-misc/xtrlock/xtrlock-2.13-r1.ebuild

41 lines
872 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="A simplistic screen locking program for X"
HOMEPAGE="http://ftp.debian.org/debian/pool/main/x/xtrlock/"
SRC_URI="mirror://debian/pool/main/x/${PN}/${P/-/_}.tar.xz"
SLOT="0"
LICENSE="GPL-3"
KEYWORDS="amd64 ppc x86"
RDEPEND="
virtual/libcrypt:=
x11-libs/libX11"
DEPEND="
${RDEPEND}
x11-base/xorg-proto"
BDEPEND="
sys-devel/gcc
>=x11-misc/imake-1.0.8-r1"
src_configure() {
CC="$(tc-getBUILD_CC)" LD="$(tc-getLD)" \
IMAKECPP="${IMAKECPP:-${CHOST}-gcc -E}" xmkmf || die
}
src_compile() {
emake CDEBUGFLAGS="${CFLAGS} -DSHADOW_PWD" CC="$(tc-getCC)" \
EXTRA_LDOPTIONS="${LDFLAGS}" xtrlock
}
src_install() {
dobin xtrlock
chmod u+s "${D}"/usr/bin/xtrlock
newman xtrlock.man xtrlock.1
dodoc debian/changelog
}