You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Apache-Reload/Apache-Reload-0.140.0.ebuild

44 lines
917 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DIST_AUTHOR=SHAY
DIST_VERSION=0.14
inherit perl-module
DESCRIPTION="Automatically reload changed modules without restarting Apache"
SLOT="0"
LICENSE="Apache-2.0"
KEYWORDS="amd64 ~arm ppc ppc64 ~riscv x86"
RDEPEND="www-apache/mod_perl"
BDEPEND="
${RDEPEND}
dev-perl/Apache-Test
test? ( dev-perl/HTML-Parser )
"
src_test() {
local MODULES=(
"Apache::Reload ${DIST_VERSION}"
"Apache2::Reload ${DIST_VERSION}"
)
local failed=()
for dep in "${MODULES[@]}"; do
ebegin "Compile testing ${dep}"
perl -Mblib="${S}" -M"${dep} ()" -e1
eend $? || failed+=( "$dep" )
done
if [[ ${failed[@]} ]]; then
echo
eerror "One or more modules failed compile:";
for dep in "${failed[@]}"; do
eerror " ${dep}"
done
die "Failing due to module compilation errors";
fi
perl-module_src_test
}