You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Digest-SHA1/Digest-SHA1-2.130.0-r2.ebuild

28 lines
560 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
DIST_AUTHOR=GAAS
DIST_VERSION=2.13
inherit perl-module
DESCRIPTION="NIST SHA message digest algorithm"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
RDEPEND="
>=virtual/perl-Digest-1.0.0
"
BDEPEND="${DEPEND}
virtual/perl-ExtUtils-MakeMaker
"
src_compile() {
mymake=(
"OPTIMIZE=${CFLAGS}"
)
perl-module_src_compile
}