You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Hook-LexWrap/Hook-LexWrap-0.260.0-r1.ebuild

31 lines
597 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DIST_AUTHOR=ETHER
DIST_VERSION=0.26
DIST_EXAMPLES=("demo/*")
inherit perl-module
DESCRIPTION="Lexically scoped subroutine wrappers"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~loong ~mips ppc ~ppc64 ~riscv sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
RDEPEND="
virtual/perl-Carp
"
BDEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? (
virtual/perl-File-Spec
virtual/perl-Test-Simple
)
"
src_test() {
perl_rm_files t/pod.t
perl-module_src_test
}