You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/IPC-Shareable/IPC-Shareable-1.130.0.ebuild

32 lines
606 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DIST_AUTHOR=STEVEB
DIST_VERSION=1.13
# Tests fail when running parallelized, see bug #797445
#DIST_TEST=do
inherit perl-module
DESCRIPTION="Share Perl variables between processes"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
dev-perl/JSON
virtual/perl-Scalar-List-Utils
>=virtual/perl-Storable-0.607.0
dev-perl/String-CRC32
"
BDEPEND="
${RDEPEND}
>=virtual/perl-ExtUtils-MakeMaker-6.720.0
test? (
>=dev-perl/Test-SharedFork-0.350.0
virtual/perl-Test-Simple
dev-perl/Mock-Sub
)
"