You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Math-ModInt/Math-ModInt-0.13.0.ebuild

43 lines
709 B

# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DIST_AUTHOR=MHASCH
DIST_VERSION=0.013
inherit perl-module
DESCRIPTION="modular integer arithmetic"
SLOT="0"
KEYWORDS="~amd64"
IUSE="minimal"
LICENSE="Artistic-2"
PERL_RM_FILES=(
"t/90_pod.t"
"t/91_pod_cover_cp.t"
"t/92_consistency.t"
"t/93_examples.t"
"t/95_versions.t"
"t/99_signature.t"
)
RDEPEND="
virtual/perl-Carp
>=virtual/perl-Math-BigInt-1.991.0
!minimal? (
dev-perl/Math-BigInt-GMP
virtual/perl-Math-BigRat
)
"
BDEPEND="${RDEPEND}
>=virtual/perl-ExtUtils-MakeMaker-6.640.0
test? (
virtual/perl-Scalar-List-Utils
virtual/perl-Test
virtual/perl-Test-Simple
)
"