You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Net-DNS-SEC/Net-DNS-SEC-1.220.0.ebuild

34 lines
784 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DIST_AUTHOR=NLNETLABS
DIST_VERSION=1.22
inherit perl-module
DESCRIPTION="DNSSEC extensions to Net::DNS"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
RDEPEND="
dev-libs/openssl:=
>=virtual/perl-Carp-1.100.0
>=virtual/perl-Exporter-5.560.0
>=virtual/perl-File-Spec-3.290.0
>=virtual/perl-MIME-Base64-2.130.0
>=dev-perl/Net-DNS-1.80.0
"
DEPEND="dev-libs/openssl:="
# pkgconfig is used to find openssl
BDEPEND="
${RDEPEND}
>=virtual/perl-ExtUtils-MakeMaker-6.480.0
virtual/pkgconfig
test? (
>=virtual/perl-Test-Simple-0.470.0
)
"