You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-perl/Sub-Identify/Sub-Identify-0.140.0-r1.ebuild

31 lines
635 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DIST_AUTHOR=RGARCIA
DIST_VERSION=0.14
inherit perl-module
DESCRIPTION="Retrieve names of code references"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
RDEPEND="
virtual/perl-Exporter
virtual/perl-XSLoader
"
BDEPEND="${RDEPEND}
virtual/perl-ExtUtils-MakeMaker
test? (
virtual/perl-Scalar-List-Utils
virtual/perl-Test-Simple
)
"
src_test() {
perl_rm_files "t/pod.t"
perl-module_src_test
}