You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/flufl-lock/flufl-lock-8.1.0.ebuild

37 lines
691 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=hatchling
PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
DESCRIPTION="NFS-safe file locking with timeouts for POSIX systems"
HOMEPAGE="
https://gitlab.com/warsaw/flufl.lock/
https://pypi.org/project/flufl.lock/
"
LICENSE="Apache-2.0"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
dev-python/atpublic[${PYTHON_USEDEP}]
dev-python/psutil[${PYTHON_USEDEP}]
"
BDEPEND="
test? (
dev-python/sybil[${PYTHON_USEDEP}]
)
"
distutils_enable_tests pytest
src_prepare() {
sed -e '/addopts/d' -i pyproject.toml || die
distutils-r1_src_prepare
}