You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/google-i18n-address/google-i18n-address-3.1.0-r...

31 lines
692 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=hatchling
PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
DESCRIPTION="Google's i18n address metadata repository"
HOMEPAGE="
https://github.com/mirumee/google-i18n-address/
https://pypi.org/project/google-i18n-address/
"
# Using the github release, as it contains the tests (unlike the pypi artifact).
SRC_URI="
https://github.com/mirumee/google-i18n-address/archive/${PV}.tar.gz
-> ${P}.gh.tar.gz
"
LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 arm64 ~x86"
RDEPEND="
>=dev-python/requests-2.7.0[${PYTHON_USEDEP}]
"
distutils_enable_tests pytest