You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-python/xdoctest/xdoctest-1.1.3.ebuild

50 lines
1.0 KiB

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1
DESCRIPTION="A rewrite of Python's builtin doctest module but without all the weirdness"
HOMEPAGE="
https://github.com/Erotemic/xdoctest/
https://pypi.org/project/xdoctest/
"
SRC_URI="
https://github.com/Erotemic/xdoctest/archive/v${PV}.tar.gz
-> ${P}.gh.tar.gz
"
SLOT="0"
LICENSE="Apache-2.0"
KEYWORDS="~amd64 ~arm64 ~x86"
RDEPEND="
dev-python/pytest[${PYTHON_USEDEP}]
"
# dev-python/nbformat-5.1.{0..2} did not install package data
BDEPEND="
test? (
>=dev-python/nbformat-5.1.2-r1[${PYTHON_USEDEP}]
)
"
distutils_enable_tests pytest
#distutils_enable_sphinx docs/source \
# dev-python/autoapi \
# dev-python/sphinx-rtd-theme
python_test() {
local EPYTEST_DESELECT=(
tests/test_pytest_cli.py::test_simple_pytest_import_error_cli
)
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
local -x PYTEST_PLUGINS=xdoctest.plugin
epytest --pyargs tests xdoctest
}