You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-qt/qtcharts/qtcharts-6.9999.ebuild

29 lines
572 B

# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit qt6-build
DESCRIPTION="Chart component library for the Qt6 framework"
if [[ ${QT6_BUILD_TYPE} == release ]]; then
KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
fi
IUSE="gles2-only qml"
RDEPEND="
~dev-qt/qtbase-${PV}:6[gles2-only=,gui,opengl,widgets]
qml? ( ~dev-qt/qtdeclarative-${PV}:6[opengl] )
"
DEPEND="${RDEPEND}"
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package qml Qt6Qml)
)
qt6-build_src_configure
}