You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-qt/qtdbus/qtdbus-5.15.13.ebuild

46 lines
705 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
if [[ ${PV} != *9999* ]]; then
QT5_KDEPATCHSET_REV=1
KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~sparc x86"
fi
QT5_MODULE="qtbase"
inherit qt5-build
DESCRIPTION="Qt5 module for inter-process communication over the D-Bus protocol"
IUSE=""
DEPEND="
=dev-qt/qtcore-${QT5_PV}*:5=
sys-apps/dbus
"
RDEPEND="${DEPEND}"
QT5_TARGET_SUBDIRS=(
src/dbus
src/tools/qdbusxml2cpp
src/tools/qdbuscpp2xml
)
QT5_GENTOO_CONFIG=(
:dbus
:dbus-linked:
)
QT5_GENTOO_PRIVATE_CONFIG=(
:dbus
:dbus-linked
)
src_configure() {
local myconf=(
-dbus-linked
)
qt5-build_src_configure
}