You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-qt/qthelp/qthelp-5.15.13.ebuild

31 lines
631 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
if [[ ${PV} != *9999* ]]; then
QT5_KDEPATCHSET_REV=1
KEYWORDS="amd64 arm arm64 ~hppa ~loong ppc ppc64 ~riscv ~sparc x86"
fi
QT5_MODULE="qttools"
inherit qt5-build
DESCRIPTION="Qt5 module for integrating online documentation into applications"
IUSE=""
DEPEND="
=dev-qt/qtcore-${QT5_PV}*:5=
=dev-qt/qtgui-${QT5_PV}*
=dev-qt/qtsql-${QT5_PV}*[sqlite]
=dev-qt/qtwidgets-${QT5_PV}*
"
RDEPEND="${DEPEND}"
QT5_TARGET_SUBDIRS=(
src/assistant/help
src/assistant/qcollectiongenerator
src/assistant/qhelpgenerator
)