You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-qt/qthttpserver/qthttpserver-6.7.0.ebuild

32 lines
574 B

# Copyright 2023-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit qt6-build
DESCRIPTION="HTTP server functionality for the Qt6 framework"
if [[ ${QT6_BUILD_TYPE} == release ]]; then
KEYWORDS="amd64"
fi
IUSE="+ssl websockets"
RDEPEND="
~dev-qt/qtbase-${PV}:6[network,ssl=]
websockets? ( ~dev-qt/qtwebsockets-${PV}:6 )
"
DEPEND="
${RDEPEND}
test? ( ~dev-qt/qtbase-${PV}:6[concurrent] )
"
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package websockets Qt6WebSockets)
)
qt6-build_src_configure
}