You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-qt/qtwebsockets/qtwebsockets-5.15.13.ebuild

30 lines
578 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
if [[ ${PV} != *9999* ]]; then
QT5_KDEPATCHSET_REV=1
KEYWORDS="amd64 arm arm64 ~hppa ~loong ~ppc ppc64 ~riscv ~sparc x86"
fi
inherit qt5-build
DESCRIPTION="Implementation of the WebSocket protocol for the Qt5 framework"
IUSE="qml +ssl"
DEPEND="
=dev-qt/qtcore-${QT5_PV}*
=dev-qt/qtnetwork-${QT5_PV}*[ssl=]
qml? ( =dev-qt/qtdeclarative-${QT5_PV}* )
"
RDEPEND="${DEPEND}"
src_prepare() {
qt_use_disable_mod qml quick src/src.pro
qt5-build_src_prepare
}