You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/dev-qt/qtwebsockets/qtwebsockets-6.7.0.ebuild

29 lines
556 B

# Copyright 2021-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit qt6-build
DESCRIPTION="Implementation of the WebSocket protocol for the Qt6 framework"
if [[ ${QT6_BUILD_TYPE} == release ]]; then
KEYWORDS="amd64 ~arm arm64 ~hppa ~loong ~ppc ~riscv ~x86"
fi
IUSE="qml +ssl"
RDEPEND="
~dev-qt/qtbase-${PV}:6[network,ssl=]
qml? ( ~dev-qt/qtdeclarative-${PV}:6 )
"
DEPEND="${RDEPEND}"
src_configure() {
local mycmakeargs=(
$(cmake_use_find_package qml Qt6Quick)
)
qt6-build_src_configure
}