You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-arcade/blockrage/blockrage-0.2.3-r1.ebuild

31 lines
649 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit toolchain-funcs
DESCRIPTION="Falling-blocks arcade game with a 2-player hotseat mode"
HOMEPAGE="https://blockrage.sourceforge.net/"
SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
DEPEND="media-libs/libsdl[video]"
RDEPEND="${DEPEND}"
DOCS=( ChangeLog KNOWN_BUGS README TODO )
PATCHES=(
# Removing error due to wrong detection of cross-compile mode
"${FILESDIR}"/${P}-config.patch
"${FILESDIR}"/${P}-statx.patch
)
src_configure() {
tc-export CC
default
}