You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-arcade/cob/cob-0.9-r2.ebuild

32 lines
637 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit desktop
DESCRIPTION="Cruising on Broadway: a painting-type game"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
SRC_URI="
mirror://gentoo/${P}.tar.gz
https://dev.gentoo.org/~ionen/distfiles/${PN}.png"
LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="media-libs/libsdl[joystick,sound,video]"
DEPEND="${RDEPEND}"
PATCHES=(
"${FILESDIR}"/${P}-gcc43.patch
"${FILESDIR}"/${P}-gcc44.patch
)
src_install() {
default
doicon "${DISTDIR}"/${PN}.png
make_desktop_entry ${PN} "Cruising on Broadway"
}