You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-arcade/frozen-bubble/frozen-bubble-2.2.1_beta1-r...

69 lines
1.5 KiB

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit desktop perl-module toolchain-funcs xdg
MY_P="${P/_/-}"
DESCRIPTION="A Puzzle Bubble clone written in perl (now with network support)"
HOMEPAGE="http://www.frozen-bubble.org/"
SRC_URI="http://www.frozen-bubble.org/data/${MY_P}.tar.bz2"
S="${WORKDIR}/${MY_P}"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
dev-lang/perl
dev-libs/glib:2
>=dev-perl/Alien-SDL-1.413
dev-perl/Compress-Bzip2
dev-perl/File-ShareDir
dev-perl/File-Slurp
dev-perl/File-Which
dev-perl/IPC-System-Simple
>=dev-perl/SDL-2.511
media-libs/sdl-image[gif,png]
media-libs/sdl-mixer[vorbis]
media-libs/sdl-pango
media-libs/sdl-ttf
virtual/libiconv
virtual/perl-Getopt-Long
virtual/perl-IO"
DEPEND="${RDEPEND}"
BDEPEND="
dev-perl/Locale-Maketext-Lexicon
dev-perl/Module-Build
virtual/perl-ExtUtils-CBuilder
virtual/perl-ExtUtils-ParseXS
virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${P}-Werror.patch
"${FILESDIR}"/${P}-fix-buffer-size.patch
)
src_configure() {
LD="$(tc-getCC)" perl-module_src_configure
}
src_compile() {
LD="$(tc-getCC)" perl-module_src_compile
}
src_install() {
mydoc="AUTHORS Changes HISTORY README" perl-module_src_install
newdoc server/README README.server
newdoc server/init/README README.server.init
local res
for res in 16 32 48 64; do
newicon -s ${res} share/icons/frozen-bubble-icon-${res}x${res}.png ${PN}.png
done
make_desktop_entry ${PN} Frozen-Bubble
}