You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/games-arcade/penguin-command/penguin-command-1.6.11-r1.e...

26 lines
597 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit desktop
DESCRIPTION="Clone of the classic Missile Command game"
HOMEPAGE="https://www.linux-games.com/penguin-command/"
SRC_URI="https://downloads.sourceforge.net/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
DEPEND="media-libs/libsdl[sound,joystick,video]
media-libs/sdl-mixer[mod]
media-libs/sdl-image[jpeg,png]"
RDEPEND="${DEPEND}"
src_install() {
default
newicon data/gfx/icon.xpm ${PN}.xpm
make_desktop_entry ${PN} "Penguin Command" ${PN}
}