You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-video/dvbsnoop/dvbsnoop-1.4.50-r3.ebuild

30 lines
532 B

# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
inherit autotools toolchain-funcs
DESCRIPTION="DVB/MPEG stream analyzer program"
HOMEPAGE="https://sourceforge.net/projects/dvbsnoop/"
SRC_URI="https://downloads.sourceforge.net/dvbsnoop/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
DEPEND="sys-kernel/linux-headers"
PATCHES=(
"${FILESDIR}"/${P}-crc32.patch
)
src_configure(){
default
eautoreconf
}
src_compile(){
emake AR="$(tc-getAR)"
}