You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/media-video/vidcutter/vidcutter-6.0.5.1_p20230201...

46 lines
1.1 KiB

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
PYTHON_COMPAT=( python3_{9..11} )
DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 xdg
MY_COMMIT="8f01c76f0ec727fa336cb2cb6a645a58e3a29e64"
DESCRIPTION="FFmpeg-based simple video cutter & joiner with a modern PyQt5 GUI"
HOMEPAGE="http://vidcutter.ozmartians.com https://github.com/ozmartian/vidcutter"
if [[ ${PV} == 9999 ]];then
inherit git-r3
EGIT_REPO_URI="https://github.com/ozmartian/vidcutter"
else
SRC_URI="https://github.com/ozmartian/${PN}/archive/${MY_COMMIT}.tar.gz -> ${P}.tar.gz"
KEYWORDS="amd64 x86"
fi
LICENSE="GPL-3"
SLOT="0"
IUSE=""
DEPEND="
>=media-video/mpv-0.25:=[libmpv]
"
RDEPEND="${DEPEND}
>=dev-python/PyQt5-5.7[dbus,multimedia,widgets,${PYTHON_USEDEP}]
dev-python/pyopengl[${PYTHON_USEDEP}]
media-video/ffmpeg[X,encode]
media-video/mediainfo"
BDEPEND="
${PYTHON_DEPS}
dev-python/setuptools[${PYTHON_USEDEP}]"
REQUIRED_USE="${PYTHON_REQUIRED_USE}"
S="${WORKDIR}/${PN}-${MY_COMMIT}"
src_install() {
distutils-r1_src_install
mv "${ED}"/usr/share/doc/{${PN},${PF}} || die
}