You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/net-libs/libident/libident-0.32-r1.ebuild

34 lines
693 B

# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
inherit autotools
DESCRIPTION="A small library to interface to the Ident protocol server"
HOMEPAGE="http://www.simphalempin.com/dev/libident/"
SRC_URI="http://people.via.ecp.fr/~rem/libident/${P}.tar.bz2"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 ~sparc x86"
IUSE="test"
# Interactive tests only.
RESTRICT="!test? ( test ) test"
src_prepare() {
default
eautoreconf
}
src_configure() {
econf \
--disable-static \
$(use_enable test testers)
}
src_install() {
default
find "${ED}" -name '*.la' -delete || die
}