You can not select more than 25 topics Topics must start with a letter or number, can include dashes ('-') and can be up to 35 characters long.
gentoo-overlay/sec-keys/openpgp-keys-oisf/openpgp-keys-oisf-20200807....

22 lines
679 B

# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DESCRIPTION="OpenPGP key used by Open InfoSec Foundation (OISF) software releases"
HOMEPAGE="https://www.openinfosecfoundation.org/"
SRC_URI="https://www.openinfosecfoundation.org/download/OISF.pub
-> oisf-B36FDAF2607E10E8FFA89E5E2BA9C98CCDF1E93A.asc"
LICENSE="public-domain"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
S="${WORKDIR}"
src_install() {
local files=( ${A} )
insinto /usr/share/openpgp-keys
newins - openinfosecfoundation.org.asc < <(cat "${files[@]/#/${DISTDIR}/}" || die)
}